Requires

3 total, all up-to-date

Package Required Latest Status
doctrine/deprecations A small layer on top of trigger_error(E_USER_DEPRECATED) or PSR-3 logging with options to disable all deprecations or selectively for packages. ^0.5.3|^1 1.1.3 up to date
psr/cache Common interface for caching libraries ^1|^2|^3 3.0.0 up to date
psr/log Common interface for logging libraries ^1|^2|^3 3.0.0 up to date

Requires (dev)

13 total, 8 outdated

Package Required Latest Status
doctrine/coding-standard The Doctrine Coding Standard is a set of PHPCS rules applied to all Doctrine projects. 12.0.0 12.0.0 up to date
fig/log-test Test utilities for the psr/log package that backs the PSR-3 specification. ^1 1.1.0 up to date
jetbrains/phpstorm-stubs PHP runtime & extensions header files for PhpStorm 2023.2 v2024.1 outdated
phpstan/phpstan PHPStan - PHP Static Analysis Tool 1.10.58 1.11.2 outdated
phpstan/phpstan-phpunit PHPUnit extensions and rules for PHPStan 1.3.15 1.3.16 outdated
phpstan/phpstan-strict-rules Extra strict and opinionated rules for PHPStan ^1.5 1.5.5 up to date
phpunit/phpunit The PHP Unit Testing framework. 10.5.9 11.1.3 outdated
psalm/plugin-phpunit Psalm plugin for PHPUnit 0.18.4 0.19.0 outdated
slevomat/coding-standard Slevomat Coding Standard for PHP_CodeSniffer complements Consistence Coding Standard by providing sniffs with additional checks. 8.13.1 8.15.0 outdated
squizlabs/php_codesniffer PHP_CodeSniffer tokenizes PHP, JavaScript and CSS files and detects violations of a defined set of coding standards. 3.9.0 3.10.1 outdated
symfony/cache Provides extended PSR-6, PSR-16 (and tags) implementations ^6.3.8|^7.0 v7.0.7 up to date
symfony/console Eases the creation of beautiful and testable command line interfaces ^5.4|^6.3|^7.0 v7.0.7 up to date
vimeo/psalm A static analysis tool for finding errors in PHP applications 5.21.1 5.24.0 outdated